Standalone builder tells me that there is a stack ... already open and so on

Richard Gaskin ambassador at fourthworld.com
Thu Feb 14 13:15:52 EST 2019


I don't have the answer to your circumstance; the Standalone Builder is 
complex, and LC's introduction of stack name conflicts not inherent in 
the MC engine has become such an ongoing issue that it might be ideal to 
revisit that sometime*.

In the here and now, I have only one tidbit to contribute which may or 
may not be relevant: stack name conflicts can appear when the path used 
to open the same stack file is different in different contexts.

This confirmed behavior is noted in this bug report from 2015:
https://quality.livecode.com/show_bug.cgi?id=14583

The example there is uses two paths that differ based on the Unix 
shortcut of "~" for the user's home folder, e.g.:

    /home/matthias/workfolder/somestack.livecode

...vs:

   ~/workfolder/somestack.livecode

Both paths refer to the same file system object, but apparently the 
engine maintains its handle to the file based on the given path rather 
than the fully resolved path, so it believes those are two different 
files in which the stack objects happen to have the same name.

So you might consider double-checking code to see if you use any 
relative path, or shortcut form, in your scripts.

But given that the same scripts worked well just a couple days ago, 
presumably with no changes to file paths in your scripts, this tidbit 
may be merely mildly interesting but irrelevant to the problem you're 
facing.


* On stack name conflicts see this enhancement request, and follow the 
link in Comment 20 there for details on the underlying engine limitation 
which gave rise to the issue:
https://quality.livecode.com/show_bug.cgi?id=1061

-- 
  Richard Gaskin
  Fourth World Systems


Matthias Rebbe wrote:

 > i´ve made some modifications to a stack today , which i compiled 2
 > daysago w/o an error.
 >
 > But today i get the following error message when trying to build a
 > Windows standalone:
 >
 > "a stack <....> is already in memory. The LiveCode UI does not
 > distinguish stacks which have identical names, so editing these stack
 > files while both are in memory could result in data loss."
 >
 > I see this error from time to time regardless what stack i am working
 > on. In the past a restart of LC solved this and i was able to compile
 > again w/o error.
 >
 > But this is not working.
 >
 >
 > The only modification i´ve done was to change the width of a field. So
 > this should not be the problem.
 >
 > I´ve checked the stack and its 12 substack. No other stack is there,
 > only the ones that should be there.
 >
 >
 > Any idea what i could do?





More information about the Use-livecode mailing list