LiveCode quits, but stays in Dock (OS X Yosemite) and shows as open

Skip Kimpel skiplondon at gmail.com
Fri Jun 26 07:16:21 EDT 2015


It probably has nothing to do with your issue (but then again it might be related) but I have noticed on a Windows machine that if I don't use "Quit" to get out of the standalone and allow the user to just "x out" of the application, it stays running in the background and you have to go into task manager to kill the process.

Luckily I can see it as a process but it does not show up as a running program.

Coincidence?

SKIP



> On Jun 26, 2015, at 3:23 AM, Kay C Lan <lan.kc.macmail at gmail.com> wrote:
> 
> Sounds like a need for some disk maintenance. When was the last time you
> ran Disk Repair and Repair Disk Permission from Disk Utility?
> 
> If it's been a while, on start-up simultaneously press the command + r
> keys. Once the computer has started in Repair Mode, select Disk Utility and
> then select your start-up disk and run Repair Disk as many times as
> necessary until it no longer reports any issues. i.e. even on the first run
> if it reports problems and it reports it fixed them all, still run Repair
> Disk again to double-check no problems reported. Then run Repair Disk
> Permissions. You only need to do this once. When it's finished run Repair
> Disk again just to double check the repairing of permissions didn't break
> something.
> 
> Hopefully when you restart your computer everything will return to normal.
> 
> Another less likely possibility is how much free space you have left on
> your HD. If it's very little then this will slow down the opening and
> closing of any document and most applications, not just one or two as is
> your case.
> 
>> On Wed, Jun 24, 2015 at 5:39 AM, Gabriel Johnson <gwjapp at gmail.com> wrote:
>> 
>> Hey All-
>> 
>> We have a weird issue on one of our computers where LiveCode (version
>> 6.6.3) seems to quit, but it remains showing as open in the Dock (on OS X
>> Yosemite). However, it says "Application Not Responding" if you right-click
>> on the icon. When I try to open LiveCode again (from the Applications
>> folder), it gives the error "The Application "LiveCode 6.6.3" is not open
>> anymore."
>> 
>> LiveCode doesn't show in the Activity Monitor, and the terminal command: ps
>> -ax | grep -i "LiveCode" doesn't show anything either. So it looks like it
>> did successfully quit. However, it shows in the "Force Quit Applications"
>> window. Choosing to Force Quit it doesn't do anything.
>> 
>> I've seen this problem with Firefox on the same computer. Does anyone know
>> what might cause this? Is there something in Yosemite I can change to
>> prevent/work around this issue? One major problem with this is that the
>> computer will not reboot unless the power button is held to force it to
>> shut down.
>> 
>> Gabe
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode




More information about the Use-livecode mailing list