Beta 2.0 save error/bug

Rodney Somerstein rodneys at
Mon Apr 7 11:22:01 EDT 2003

>In testing 2.0 Beta, I opened an old stack file, worked with it and 
>tried to save my changes (the changes actually consisted of only 
>updating the name property of the stack. Instead of saving, I got 
>the following error:
>     	executing internal 10:32:11 AM
>Type	Chunk: can't find stack
>Object	revBackScript
>Line	if the mainStack of stack l is not among the lines of 
>tStacksList then put l & cr after tFinal
>Hint	button id 1041 of card id 1002 of stack 
>"/Applications/Revolution 2.0 B1/components/global 
>If I click the Ignore button, the error box comes right back up with 
>the message "internal" and nothing else. I had to force-quit Rev in 
>order to get rid of the message.
>What does this actually mean? Is it a bug in 2.0 or is there 
>something I am doing incorrectly?

Just to expand on this a little further:

First of all, I'm using Mac OS X 10.2.4 (forgot to mention that earlier).

Second of all, here is the recipe for duplicating the error:

Open Rev. Select New Mainstack from file menu. Open stack inspector. 
Save the stack (name doesn't seem to matter). In stack inspector, 
change the name property, but leave the cursor in the field (don't 
click elsewhere after typing the new name - I've simply added a 3 
after the existing name so the new name is Untitled 13. Save the 
stack and the error occurs.

Also, for some reason I get a floating "-" sign in the middle of my 
stack window when this error occurs. The - sign has the same color as 
the window (white) but has a black outline and drop shadow.

One more also - can the error dialog be changed to wrap text? I 
shouldn't have to expand the window or scroll to the right in order 
to see the error message.


More information about the use-livecode mailing list