[revMobile] could not play sound

Nicolas Cueto niconiko at gmail.com
Fri Aug 20 01:15:44 EDT 2010


Just got the latest build of the RevMobile plugin and am testing out
(among other interesting things) the sound playback on iPhone and iPad
of a revMobile-built app. In the IDE, the sound works, but in the real
devices themselves and in the iPhone simulator, no sound!

I've tried with wav, aiff, and mp3 soundfiles.

And I've tried with these files located as URLs and in the application
itself (using Rev's "File > Import sound").

The button scripts are:

on mouseUp
   play "helloWorld.wav" -- the imported soundfile
   put the sound & cr & the result into field "result"
end mouseUp

on mouseUp
   put tTheURLPath & "helloWorld.wav" into tPath
   play tPath
   put the sound & cr & the result into field "result"
end mouseUp


And the result feedback from these shown on my iPhone and iPad:

   done
   could not play sound



Tried using the system beep a too, like this:

on mouseUp
   beep
end mouseUp

But, nothing heard that way either.

Any ideas?

Please note I realize RevMobile explanatory note's warn sound playback
is "somewhat buggy" in the iPhone simulator. But, as I say, this sound
playback problem happens both in real devices and in the simulator.

Thank you.

--
Nicolas Cueto



More information about the Use-livecode mailing list