doMenu

J. Landman Gay jacque at hyperactivesw.com
Wed Nov 22 23:46:57 EST 2006


Mikey wrote:
>> I wonder why you would send the edit command instead of just executing 
>> it?
> See previous:  Because.  It.  Doesn't.  Work.
> 
> 
> UPDATE:  I have been poking around in the IDE for a couple of days
> trying to figure out why when RR's IDE stacks "edit..." it works, but
> I can't get it to work.  Then today I tried putting the script in a
> button, and it worked.
> 
> So, typing "edit the script of this stack" in the message box, or
> having a handler

Typing "edit script of this stack" into the message box works fine here. 
I do this routinely many times a day. No problems so far.

> on s
>   edit the script of this stack
> end s
> 
> doesn't work.

I put the above handler into the script of a new stack. I typed "s" in 
the message box. The script opened and was as you say, uneditable. So 
yes, a bug.

But if I change the script (which is still in the stack) to this:

on s
  edit script of cd 1
end s

Then it works as expected. So apparently the lockup only happens if the 
script that is running tries to edit itself. That makes some kind of 
obscure sense to me, but probably should still be called a bug.

-- 
Jacqueline Landman Gay         |     jacque at hyperactivesw.com
HyperActive Software           |     http://www.hyperactivesw.com



More information about the Use-livecode mailing list