MP3 without QuickTime on Windows

Ben Rubinstein benr_mc at cogapp.com
Wed Feb 9 13:05:17 CST 2005


Hi Klaus

> Quick guess:
> 
> Did you "set the dontuseqt to true"?
> In an "preopenstack"-handler or something...
>
> I think even if QT is NOT present the engine thinks to have to use
> QT...?

I haven't; but I don't think it's relevant, as the same app on a PC running
'ordinary' windows XP works fine - if QT is installed, it uses QT; if QT is
uninstalled, it uses Media Player.

Can RunRev confirm the actual requirements, or give me a clue how to debug
what's not working?  (EG on OS X I now about using the console to get
detailed info about what's failing to work when it tries to access some
external component; is there some equivalent on Windows (XPe) that I can use
to figure out what the problem is here?
 
  Ben Rubinstein               |  Email: benr_mc at cogapp.com
  Cognitive Applications Ltd   |  Phone: +44 (0)1273-821600
  http://www.cogapp.com        |  Fax  : +44 (0)1273-728866


> From: Ben Rubinstein <benr_mc at cogapp.com>
> Date: Tue, 08 Feb 2005 15:48:38 +0000
> To: "use-revolution at lists.runrev.com" <use-revolution at lists.runrev.com>
> Subject: Re: MP3 without QuickTime on Windows
> 
> Hi Klaus,
> 
> Thanks for your help already.  I'm making progress, but I'm not quite where I
> wanted to be yet.
> 
> As noted in my previous post, I'm trying to play MP3s on a minimal
> installation of Windows XP Embedded.  I don't have direct control over the XPe
> build (and wouldn't know what I was doing if I did) - I try something, make a
> fresh request, get a new solid state disk for the unit, try again.  Quite
> longwinded, and there's a tight timetable on this project.
> 
> As noted before, I removed QuickTime from a normal PC running XP, and played
> MP3 files, using a 'quicktime player', without problems (and without a
> controller, which is fine).    I wasn't previously able to install either
> Media Player or QuickTime on the XPe unit.
> 
> I've now got a new disk for the XPe unit, with MediaPlayer.  I can play an MP3
> file directly by double-clicking, it opens MediaPlayer, plays it fine no
> problems.  However, from Rev I still get 'could not open video player' when I
> set the filename of the player to the MP3 file.
> 
> I am also now able to install QuickTime (version 4!) on the XPe unit; and can
> then play the MP3 from Rev fine, complete with controller.  But when I
> uninstall QuickTime, I'm back to square one.
> 
> I then tried getting Media Player 9 for XP from the MS website, and installing
> that.  Installation apparently proceeded without a problem, and Media Player
> can play the content without problems - but the symptoms when playing from Rev
> are the same.
> 
> Evidently all installations of Media Player are not equal.  Can you (or
> anyone) clue me in to what I need (and preferably how to express this to the
> people building the disk image)?
> 
> If we have to, we might be able to get away with QuickTIme - but it will cause
> other difficulties, so if we can avoid it just to play MP3 files that would be
> an advantage.
> 
> Thank you,
> 
> Ben Rubinstein               |  Email: benr_mc at cogapp.com
> Cognitive Applications Ltd   |  Phone: +44 (0)1273-821600
> http://www.cogapp.com        |  Fax  : +44 (0)1273-728866



More information about the use-livecode mailing list