use-revolution Digest, Vol 11, Issue 1

pkc pkc at mac.com
Sun Aug 1 11:39:58 CDT 2004


Many thanks to all for the suggestions.  If it helps round out the 
problem, I can reply to these comments:

Troy wrote:

>I honestly think your executable is just getting "munged" in the
>transfer. Create the executable into a new folder, stuff (zip,
>whatever) the entire folder immediately. Move that to the PC and
>extract. Hopefully, everything will work properly after that. The rest
>of the items you mentioned (ask and answer dialogs, fonts, etc.) could
>cause flakey behaviors and visual anomalies - but shouldn't prevent the
>app from running.


That's the most logical, and I would be satisfied with that answer if 
we hadn't tried every way I know of, and hundreds of repeats, of 
transferring the files from my G5 or G4 desktops (where they look 
like regular old .exe files) to a Windows desktop, where they look 
like bundles.  I see what you mean about the apparent lack of any 
venue for interference from dialog stacks or fonts. I zapped the 
alternative ask dialog stack anyway, at which point the app picked up 
my global profile formatting (dropping the generic stuff) and looked 
snappy anyway. Still trying to share the brilliance with my Windows 
users!


Chipp wrote:

>Have you tried compiling it on a Windows machine? If you don't have a
>license, perhaps you can post your stack to a server and we can try
>compiling it for you?

Thanks, Chipp.  I've had a few friendly offers for this, and will try 
it as a last ditch effort.  Sounds like it must be a sure-fire fix, 
but it doesn't quite offer a modus vivendi for the future. I have a 
day or so to try more specific fixes that might give me an idea what 
the #@!#$%^ the problem is.

>Also, when creating a new standalone, make sure and do the following:
>
>Create a brand new folder first.
>Save your standalone to the brand new folder.
>
>There was a bug in the standalone builder on 2.2 which wouldn't build
>correctly if there was a folder or file name conflict.

Ah yes, Troy also mentioned building into a fresh directory.  This 
sounds promising indeed. I haven't been doing that, at least not 
consistently.

>And, I might add, try removing your Windows engine and have the
>standalone builder automatically download it again.

The problem with that is that I wasted about a week at the beginning 
of this trauma trying to get my 2.2.1 and 2.2CR2 standalone builders 
to download the Win32 engine. I thought it was a traffic error or 
something (the standalone was kind of characterizing it this way with 
the progress bars and all), but finally I appealed to Heather and it 
seemed that the standalone was never actually addressing the correct 
directory to download that little file. I downloaded it manually and 
finally got a build (then on to the second and far stranger of the 
problems).  I can only get the file with the manual download. I'm 
happy to do it repeatedly to make sure I get a good catch. But it is 
impossible for me to use my present build of the standalone to do it.

My program of fixes (now under weigh) is:

1) Rename the current file on the FTP server with a "zip" suffix. 
Have unwitting subjects download it and see what happens.Transfer 
said renamed fake zip via disk and try to open. Probably won't work, 
but would tell a lot if one or both did.

2) Actually compress the file with Stuffit, replace the old file on 
the server, proceed as above.Transfer said genuine zip via disk and 
try to open.  I figure, slightly better chance of success?

3) Reinstall Revolution, re-download Win32, rebuild everything, zip, 
proceed as above.

4) Transfer the stack file to some Windows machine somewhere running 
Revolution and build the thing.  Has to succeed, no?  But we would 
learn nothing.

5) Flunk the 80 percent of the students in the course who are using 
Windows, on the grounds that their work is incomplete.  Attractive in 
its way.


More information about the use-livecode mailing list