Type 3 on revdb_connect, but ODBC drivers okay

Robert D. Rasmussen brasmussen at earthlink.net
Sun Dec 30 03:36:01 EST 2001

I've tried every variation I can think of, but still no luck getting database functions to work.

I'm pretty sure that the ODBC drivers are installed correctly, and that the databases and ODBC control panel settings are right, because I can get to the database via ODBC from Excel without errors.

Trying to get use Revolution's Database Manager tool, however, causes Revolution to crash with an error of Type 3 (illegal instruction) when I attempt to connect. I can't get it to work from my own scripts either.

I've read the Help section of the Database Manager tool and noted the comment about Revolution crashing if the ODBC drivers aren't installed. I don't think this explains my problem. I've also looked through the archives on your web site for information about such problems, but I haven't discovered any.

Are there other possibilities?

More details:

I'm running MacOS 9.1 on a PowerMac G3.

The databases are in FileMaker Pro 5.  The databases are shared over TCP/IP with Remote Data Access Companion installed and enabled (I've also tried Local Data Access Companion, but the symptoms are identical).

The INTERSOLV ODBC v3.11 Drivers are installed on the system.

I have created a User DSN in the ODBC Setup PPC control panel. It uses the ODBC 3.11 FileMaker PPC driver. "Use Remote Connection" is checked and the IP of the FileMaker server is specified (no port number -- but I've tried both with and without).  [I unchecked the box when using Local.]

I'm using Revolution 1.1. In the Database Manager tool, I'm using the User Datasource Name from the ODBC Setup PPC control panel as the Host (I've tried other things), and one of the open database names in FileMaker as the DataBase (I've tried other things here too). I'm also specifying both a user name and password (though FileMaker doesn't require a user name).

The crash always occurs on the revdb_connect call in the script, whether from the Database Manager tool or from my own script.

Queries from Microsoft Excel (via Microsoft Query) show the User Datasource from FileMaker, as specified in the ODBC Setup PPC control panel (except with an asterisk appended to the name -- I've even tried mimicking that).  All shared, open files in FileMaker appear for access, and all fields in the files are visible. Password prompts are displayed and accepted. The query completes without error, and the data that is imported into Excel is correct.  This leads me to believe that the problem is neither with FileMaker nor with the ODBC driver setup.

More information about the use-livecode mailing list