Live code Server revOpenDatabase help needed

Ralph DiMola rdimola at
Wed Jul 15 08:36:34 EDT 2020


I ran into this when I updated to 64 bit. It was a script only library
stack. I don't know why it worked in v6 but did not work in v9. For me it
was fastJson.livecodescript that caused the problem so I just used the built
json in v9 and all was OK. Why it showed up in a DB open is a mystery?

Ralph DiMola
IT Director
Evergreen Information Services
rdimola at

-----Original Message-----
From: use-livecode [mailto:use-livecode-bounces at] On Behalf
Of kevin--- via use-livecode
Sent: Wednesday, July 15, 2020 6:08 AM
To: use-livecode at
Cc: kevin at
Subject: Live code Server revOpenDatabase help needed


I've been running a very old (32bit lc server v6 on Ubuntu 16) for years and
the following script works to connect to the SQL database.
My new(er) server (64bit lc server v9 on Debian 8) throws up ~Function:
error in function handler (revOpenDatabase)~ so something has clearly
changed. I've tried removing the socket references, changing the connection
type but the error message remains the same. Has the syntax for
revOpenDatabase changed and I'm reading old documentation again?


# connect to the database
command dbConnect
put "/var/run/mysqld/mysqld.sock" into _Socket
	put revOpenDatabase("MySql", "localhost:3306", _dbName, _dbUser,
_dbPass,, _Socket) into DB
	if DB is not a number then put "Error: could not connect to
database!" & BR end dbConnect

use-livecode mailing list
use-livecode at
Please visit this url to subscribe, unsubscribe and manage your subscription

More information about the use-livecode mailing list