Encrypting Stack Breaks Field References

Ron Noice revlist at ecion.ca
Sun Dec 13 15:15:03 EST 2020

My program (built with LC 9.6.1 Indy Windows) contains a large number of references to fields by variables. For example, instead of refering to [fld "abc"] I refer to [fld tName] where tName is a variable containing "abc" (no quotes).

This has worked perfectly until I *encrypted* the stack (through the standalone settings). The standalone itself works with no problem; only when I encrypt it does it fight back. Here's a simplified example of what I'm doing:

create group "grpTree"
copy fld "baseBox" to grp "grpTree"
set the name of it to tName
set the visible of fld tName to true

This gives me a "no such object" error on the "set the visible" line. Through testing, I've determined that
- tName holds the correct value 
- a field named with the value of tName has been correctly created
- but it still seems to be the reference to [fld tName] that is the problem

This is about building family trees on-the-fly. The largest I've worked with so far has over 450 boxes (fields) in the tree all with connecting lines and all based on the ability to use variables to refer to the fields. At the moment I'm just leaving the stack unencrypted. But inquiring minds would like to know what the problem is. I know others have used this syntax for naming and am sure some of them must have encrypted their stacks. Clearly I'm missing something. 

Thanks for any brilliant suggestions you may have.

... Ron

More information about the use-livecode mailing list