Big problems creating standalone

Paul Dupuis paul at researchware.com
Sun Jun 9 10:32:50 EDT 2019


On 6/9/2019 9:28 AM, Klaus major-k via use-livecode wrote:
> Hi friends,
>
> I have an old stack with 18 substacks from 2012.
> I saved it in current format with LC 9.04 on macOS 10.14.5.
>
> I selected 64bit in the standalone application settings and tried to create
> a standalone, but had to cancel (CMD+. period did not work I had to quit
> with CMD+Q) LC, which worked without problems!?
>
> It "hung" at, see also below:
> Removing development properties and setting profile options...
> for about 20 minutes before I quit. I had checked "Remove all profiles on objects".
>
> Then I applied the new "standalone fix" to the two appropriate handlers in my stack:
> on preopenstack
> if the environment = "development" and there is a stack "revStandaloneProgress" and the mode of stack "revStandaloneProgress" > 0 then
>   exit preopenstack
> end if
> ...
>
> And:
> on openstack
> if the environment = "development" and there is a stack "revStandaloneProgress" and the mode of stack "revStandaloneProgress" > 0 then
>   exit openstack
> end if
> ...
> I don't have any closestack, closecard or pre-/opencard handlers in the scripts.
>
> But now I get a long errorlist starting with:
> There was an error while saving the standalone application
> 91,1764,1
> 77,1764,1
> 449,1764,1
> 535,1764,1
> 353,0,0,stack "path to.../../../revsaveasstandalone.livecodescript"
> ...
> !?
>
> The line in question 1764 of that stack is in fact a COMMENT in handler:
> private command revSetStackProps pStack
>    ...
>    lock screen
>    lock messages
>    revStandaloneProgress "Removing development properties and setting profile options..."
>    set the wholeMatches to true
> ## This is line 1764:
> --remove profiles from all objects
>    if sStandaloneSettingsA["setToProfile"] is not "" then put true into tSetTo
>    -- stack properties
> ...
>
> And 91 means "Stack not found"?
> WTF? What stack? Is this a bug?
>
> Any hints highly appreciated, thanks a lot in advance!
>
>

I too have run into standalone building errors where there was a dump of 
triplet numbers trying to built a complex app originally built under 
LC5.5.x in 904 or 905rc1, but as we have been able to build in 904 on a 
different computer (in ourcase it was building for OSX under Windows 
that through the errors, but building for OSX under OSX worked) we've 
just moved on and have not troubleshot the problem further. Just not 
enough time.

So I can't say if it was the same error or not.





More information about the Use-livecode mailing list