ITMS-90546: Missing Asset Catalog

Dan Friedman dan at clearvisiontech.com
Wed Jul 24 12:30:24 EDT 2019


Panos,

My app does not support landscape and I have "Portrait" selected in the "iPhone Initial Orentation".  For this reason, I did not include Landscape spash screens.   Could this be the issue?

-Dan
 

On 7/24/19, 9:09 AM, "use-livecode on behalf of Dan Friedman via use-livecode" <use-livecode-bounces at lists.runrev.com on behalf of use-livecode at lists.runrev.com> wrote:

    Panos,
    
    I did include all icons and splash screens.  No, there is not a "Assets.car" in the app bundle.   Here's what's in the bundle:
    _CodeSignature
     > CodeResources
    AppIcon60x60 at 2x.png
    ca-bundle.crt
    Default-568h at 2x.png
    Default-667h at 2x.png
    Default-736h at 3x.png
    Default-812h at 3x.png
    Default-896h at 2x.png
    Default-896h at 3x.png
    Default.png
    Default at 2x.png
    embedded.mobileprovision
    Info.plist
    PkgInfo
    myApp
    
    -Dan 
    
    On 7/24/19, 8:58 AM, "use-livecode on behalf of panagiotis merakos via use-livecode" <use-livecode-bounces at lists.runrev.com on behalf of use-livecode at lists.runrev.com> wrote:
    
        Hello Dan,
        
        Yes, the standalone builder creates this for you (you need to supply
        correct icons and splash screens for all supported devices).
        
        Does the standalone app bundle contain a file called "Assets.car"?
        
        Best,
        Panos
        --
        
        On Wed, 24 Jul 2019 at 18:29, Dan Friedman via use-livecode <
        use-livecode at lists.runrev.com> wrote:
        
        > Using LC 9.5.0 (dp 1), I uploaded my app to Apple.  I got this back from
        > them:
        >
        > ITMS-90546: Missing Asset Catalog - Your app is missing the asset catalog
        > file in yourApp.app'. For more information see
        > http://help.apple.com/xcode/mac/current/#/dev10510b1f7.
        >
        > A "Asset Catalog" doesn't sound like something I should be adding
        > manually.  Could this be an issue with LC when building the standalone?
        >
        > -Dan
        >
        > _______________________________________________
        > use-livecode mailing list
        > use-livecode at lists.runrev.com
        > Please visit this url to subscribe, unsubscribe and manage your
        > subscription preferences:
        > http://lists.runrev.com/mailman/listinfo/use-livecode
        >
        
        
        -- 
        Panagiotis Merakos <panos.merakos at livecode.com>
        LiveCode Software Developer
        
        Everyone Can Create Apps <https://livecode.com>
        _______________________________________________
        use-livecode mailing list
        use-livecode at lists.runrev.com
        Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
        http://lists.runrev.com/mailman/listinfo/use-livecode
        
    
    _______________________________________________
    use-livecode mailing list
    use-livecode at lists.runrev.com
    Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
    http://lists.runrev.com/mailman/listinfo/use-livecode



More information about the Use-livecode mailing list