Weird LiveCode Plugins Prefs writing problems

William Prothero waprothero at
Sun Feb 10 18:04:55 EST 2019

Problem solved, but first:
I found that BitDefender kept deleting the “Safe Application” setting for “Livecode Business 9.0.2”, so it blocked writing to the Devo Prefs file. The OS wouldn’t let me delete the library files associated with BitDefender. I also found that there were un-fixable errors in my boot drive, which is an SSD drive. I wanted to delete all anti-virus files and CleanMyMac, which contained both version 3 and X. I also needed to deal with the boot drive disc errors, which DiskUtility couldn’t fix. I was going to have to completely erase and reformat the boot drive. Fortunately, my boot drive was still functioning mostly normally.

First I booted my computer from an external drive that I had created a couple of weeks ago using SuperDuper. Then I deleted all Library files related to BitDefender and CleanMyMac. I think I got all of them, but may have missed something.

Next I created a disc image big enough to hold all of my boot drive content (on an external drive), so I could restore it after reformatting. I used SuperDuper to copy my boot drive content to the disc image. Then I reformatted my original boot drive and after that, used SuperDuper to copy the disc image contents back to my original boot drive.

I checked that the Devo prefs were being updated correctly, and yes, they were. Problem solved.

I’m a bit afraid to leave off a virus protection program though. Anybody have recommendations?


> On Feb 10, 2019, at 6:55 AM, Brian Milby via use-livecode <use-livecode at> wrote:
> Guess I waited until the right time to go from 10.12 to 10.14 :grin:
> I’ll be doing that upgrade in the next couple weeks.
> Thanks,
> Brian
> On Feb 10, 2019, 7:49 AM -0500, Sannyasin Brahmanathaswami via use-livecode <use-livecode at>, wrote:
>> Little story: Yesterday, early the morning, I was on 10.4.2. "Sadly" I thought Navigator would not save preferences. Went back to work, thinking the IDE has lost some globals, or messages, it crashes for me all the time now, at least once a day. No point sending in reports, Panos says "cannot reproduce..."
>> Besides, two other programs unrelated, will suddenly "wink out" I say that, because, you may be doing something else, the application is not experiencing any "user operations". Suddenly it crashes and you get a crash report. It's as if a gremlin in the background is issuing a "Kill process." Although it also happens in the IDE, especially when dragging a control from the tool bar onto a stack. I always save, hold my breath now when create a button, drag it the tools pallet "Oh no! the IDE crashed, again...sigh" Now, that seems unrelated... but
>> Not paying much attention update notices. Busy getting work done. I hard to reboot. Ha! big update got installed. OS X 10.4.3
>> Now, this morning Navigator prefs are saved.... Yay! Having done nothing else, one is tempted to say, it was a "mysterious OS thing"
>> I never had time to investigate... Rick: I'll try Avast
>> BR
>> Bill wrote: So I used diskutility to repair the system drive, then updated the os to 10.14.3.
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> _______________________________________________
> use-livecode mailing list
> use-livecode at
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:

More information about the Use-livecode mailing list