Devolution Problem

Richard Gaskin ambassador at fourthworld.com
Fri Feb 8 17:25:39 EST 2019


William Prothero write:

 > Richard:
 > Hi, I am having a problem getting Devolution to save new projects in
 > the project browser. I enter a new project, it shows up and opens
 > normally, but if I quit Livecode, it doesn’t save the most recent
 > project I entered, although previously entered projects continue to be
 > listed. I haven’t tried to add new projects for awhile, so don’t know
 > if it the last Devo or OS upgrade broke something, or I’m doing
 > something wrong.
 >
 > I am on Mac OS 10.14.2, LC 9.0.2. But, I tried LC 8.2.0 (dp2) and Devo
 > behaves the same way. In the folder “../Plugins/FourthWorld.com/“
 > folder, the 4wDevolutionPrefs.pref <http://fourthworld.com
 > /4wDevolutionPrefs.pref>” file has an empty file "4wDevolutionPrefs~”,
 > so it tried setting up the file, but couldn’t replace the existing
 > file. I changed the permissions of the prefs file to read/write for me
 > and everybody, but still same problem.
 >
 > What should I try next?

Just to be safe, run the disk scan and permissions repair tools in 
Apple's Disk Utilities.

The presence of the "~" shows the devolution plugin is attempting to 
save its prefs info as expected, but being an empty file suggests 
something is preventing the write from happening in the middle of the 
operation.

It may also be that another plugin is intercepting the save or otherwise 
interfering with normal operation.  If Disk Utility shows no issues with 
the storage media or format then you may consider a test run in which 
you first remove any third-party plugins which may interfere with other 
stacks' activity.

Let me know what you find, either here or email or a phone call, 
whichever is best for you.

-- 
  Richard Gaskin
  Fourth World Systems
  Software Design and Development for the Desktop, Mobile, and the Web
  ____________________________________________________________________
  Ambassador at FourthWorld.com                http://www.FourthWorld.com




More information about the Use-livecode mailing list