LC9 and Windows Unicode bug?

Brian Milby brian at milby7.com
Tue May 29 20:04:22 EDT 2018


I'm seeing the same results Mac Sierra / Win 10.  But, you can open the
file as binary.

...
open file theFile for binary read
...

Function Readln FILE_NAME
   Read from file FILE_NAME until Return
   Delete last char of it
   Return textDecode(it,"UTF-8")
End Readln

Function Readbk FILE_NAME
   Read from file FILE_NAME until numToChar(1)
   Delete last char of it
   Return textDecode(it,"UTF-8")
End Readbk

When I change to reading the file as binary, then I get the same (as far as
I can tell) results left/right fields.

On Tue, May 29, 2018 at 4:35 PM, Paul Dupuis via use-livecode <
use-livecode at lists.runrev.com> wrote:

> I have found a bug in LC9.0.0 under Windows 8.1 that does not appear
> under OSX (Mavericks).
>
> When reading a UTF-8 file via Open File, Read From File, Close File (vs
> say a Put URL ...into tVar; put textDecode(tVar,"UTF-8") into ...) I am
> seeing a problem decoding Traditional Chinese and Japanese characters.
>
> The bug report below has a ZIP file with a test stack and a UTF-8 file
> to show the problem
>
> https://quality.livecode.com/show_bug.cgi?id=21316
>
> Can any one on this list with a Windows 8.1 or Windows 10 system and
> LC9.0.0 (stable) spare a few minutes and verify this bug for me?
>
> Thank you in advance.
>
>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>



More information about the Use-livecode mailing list