Is anyone using tsNet external with LCserver?

Charles Warwick charles at techstrategies.com.au
Tue May 29 03:57:37 EDT 2018


Hi Matthias,

Just to check - did they install the Indy version of the tsNet external?

Regards,

Charles

> On 29 May 2018, at 5:37 am, Matthias Rebbe via use-livecode <use-livecode at lists.runrev.com> wrote:
> 
> Hi Charles,
> 
> thanks. Unfortunately it does not work. I have a Hosting account at HostM.com <http://hostm.com/>. They installed a Livecode server commercial version for me  for all of my accounts months ago, so i do not have to install it for every addon domain folder.
> Today they installed the tsNet External into the Externals folder for me. But it was not working.
> I get this error message:
> file "/home/ua82xxxx/public_html/domain1/index.lc"
>  row 2, col 1: Handler: can't find handler (tsNetinit)
> This is what they replied to support request.
> "It looks like you may have to contact the developer of tsNet so they can look into this and run some tests on their end.
> The issue is complicated by the fact that the following commands do not currently seem to work properly on LiveCode Server (9.0.0) in order to verify which externals and their functions etc. have been loaded:
> put the externals of stack “Home"
> put the externalCommands of stack “Home"
> put the externalFunctions of stack “Home"
> put the externalPackages of stack “Home”
> With all of the above command always returning empty, there becomes more difficult to determine if the issue that you’re experiencing is caused by tsNet not wanting to load to begin with, or by a bug in tsNet itself, but the developer should be able to look into this.”
> 
> Any idea what might cause this.
> 
> Regards,
> 
> Matthias
> 
> 
>> Am 28.05.2018 um 05:49 schrieb Charles Warwick via use-livecode <use-livecode at lists.runrev.com>:
>> 
>> Hi Matthias,
>> 
>> You should just need to copy the relevant tsNet external (for Linux x64 it is tsNet-x64.so) into the external directory from your normal commercial desktop installation.
>> 
>> After that, just make sure you call tsNetInit before making any other tsNet calls.
>> 
>> Regards,
>> 
>> Charles
>> 
>>> On 28 May 2018, at 9:06 am, Matthias Rebbe via use-livecode <use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>> wrote:
>>> 
>>> Hi,
>>> is anyone already using tsNet external with Livecode server? If so, is there something i should take care of when trying to “install” / copy the external to my custom installation?
>>> 
>>> Unfortunately the commercial LC server builds still do not contain the external.
>>> 
>>> Regards,
>>> 
>>> Matthias Rebbe
>>> 
>>> 
>>> 
>>> 
>>> _______________________________________________
>>> use-livecode mailing list
>>> use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>
>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-livecode <http://lists.runrev.com/mailman/listinfo/use-livecode>
>> 
>> 
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode <http://lists.runrev.com/mailman/listinfo/use-livecode>
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list