"module format not supported"

Ben Rubinstein benr_mc at cogapp.com
Mon Feb 5 06:03:56 EST 2018


I had a little module (two actually - both derivatives of the LiveCode Line 
Graph widget). In a stack that I only used in the IDE, so this is nothing to 
do with standalones. I last used this stack two weeks ago - almost certainly 
under LC 8.1.8, if not 8.1.7.

Last week I installed and at least briefly used both LC 8.1.9 rc 1 and 9.0.0. 
dp 11.

Today I went to use this stack again, and found the component on the page 
empty. Looking at the Extension Manager, both widgets are labelled "Module 
format not supported".  Quit and relaunch doesn't help. Just in case my memory 
is faulty, I tried opening the stack in 8.1.7 - one of the widgets doesn't 
appear in the list at all, the other is labelled "Module format not supported".

So I have two questions:

1) What does this mean and what should I do about it

2) Should launching a newer build of LC do something to corrupt user modules 
in this way?


I assume that there's been a change in module format, and LC 9 (I assume) 
automatically updated the ones it found to the new format, thus breaking them 
for earlier versions.  Obviously given that LC9 is dp, so it's reasonable to 
assume that the user is still running something more stable in parallel with 
reviewing LC9, it would be polite to at least ask the user if they want these 
modules updated or ignored.

So my third question is where should I have read something that would have 
told me about this change?

TIA,

Ben




More information about the Use-livecode mailing list