preOpenCard not running on iPhoneX simulator

Mike Kerner MikeKerner at roadrunner.com
Sun Dec 16 16:12:48 EST 2018


Trap inside the preopencard handler.  LC fails silently in built
applications, so if some code or routine that is either directly or
indirectly triggered by the preopencard handler fails, the handler will
just stop executing.
You might be able to find out what's going on with the mobile debugger, too.

Do do it with code, try
on preopencard
answer "poc"

answer "pre doSomething"
doSomething
answer "dosomething achieved"

answer "preDoSomethingElse
doSomethingElse"
answer "doSomethingElse achieved"

answer "end poc"
end preopencard

On Fri, Dec 14, 2018 at 7:14 AM Alan via use-livecode <
use-livecode at lists.runrev.com> wrote:

> I'm having a strange issue with a mobile app - on the 11.2 simulator a
> preOpenCard handler doesn't seem to run on the iPhoneX simulator but does
> with other devices.
>
> What might be stopping this handler from running on the X simulator but
> not on others? Any ideas?
>
> Strangely, when I make a barebones test stack with only a preOpenCard
> handler, it runs ok on the X simulator. So that points to something in my
> original stack... but  what can stop the preOpenCard message from being
> sent??
>
> cheers
>
> Alan
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
>


-- 
On the first day, God created the heavens and the Earth
On the second day, God created the oceans.
On the third day, God put the animals on hold for a few hours,
   and did a little diving.
And God said, "This is good."



More information about the Use-livecode mailing list