eBook Academy error

andrew at midwestcoastmedia.com andrew at midwestcoastmedia.com
Wed Apr 4 09:00:05 EDT 2018


I have some students working through the LiveCode academies in class  
and have found an error in the first lesson (previously we have  
encountered issues with the Parallax Effect lesson). On the Project  
Setup and Splash Screen, the user is instructed to play a splashscreen  
video by doing the following:

	play videoClip (specialfolderpath("desktop") &  
"/BitterRevenge/Video/Intro.mp4")

When I go to the Dictionary to search for the term videoClip I see it  
was introduced in 1.0, but I have to read all the way to the end of  
the entry to find out this was deprecated in 8.1 (and isn't indicated  
at the top of the entry or with a ! in the list before selecting the  
entry). The dictionary entry also seems to be missing bits and pieces  
(I thought this was a filed bug, but couldn't find it in Bugzilla)  
reading unintelligible like this:

...
The use of was deprecated in version 8.1 of LiveCode with new defaults  
for and as true on all systems apart from pre OS X 10.8. The Windows  
build of LiveCode no longer supports any features and setting the and

will have no effect. Additionally does not include 64 bit support and  
therefore can not be supported on OS X 64 bit builds of LiveCode.
...

I showed the student how to use a player object and execute the play  
player command as a workaround. Does this get filed as an Enhancement  
Request, email to support, or both?

--Andrew Bell





More information about the Use-livecode mailing list