Odd Name Resolution

Randy Hengst iowahengst at mac.com
Wed Apr 4 08:39:15 EDT 2018


Bob,

This works for me when I’m on the card with the button:
put "btn: Set10to15" && the hilited of button "Set10to15"


This works for me on any card in the stack:
put "btn: Set10to15" && the hilited of button "Set10to15" of cd "GameCardHD"


The button I’m referencing is in a group on the cd "GameCardHD" 

Any chance you have two buttons with the same name on the card? Perhaps same name, but in different groups? I ask, because I seen similar results as you describe when I’ve done both of those things.

be well,
randy

Randy Hengst
www.classroomFocusedSoftware.com


> On Apr 3, 2018, at 5:38 PM, Bob Sneidar via use-livecode <use-livecode at lists.runrev.com> wrote:
> 
> I will try to throw one together. Note that it isn't returning an error, which it would if the defaultStack was something else, and the button or card did not exist. It's not doing that. It's returning a false value. 
> 
> Bob S
> 
> 
>> On Apr 3, 2018, at 15:32 , Tom Glod via use-livecode <use-livecode at lists.runrev.com> wrote:
>> 
>> hmmm....thats really weird ...... maybe one of the IDE stacks is being
>> considered as the defaultstack.... i don't know why else the ref would not
>> work....
>> 
>> it really is weird.... you should report it....can you post a stack?
> 
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode




More information about the Use-livecode mailing list