Moving on from 8.* to 9.*

Mark Wieder ahsoftware at sonic.net
Wed Sep 20 17:33:46 EDT 2017


On 09/20/2017 01:09 PM, Sannyasin Brahmanathaswami via use-livecode wrote:

>      I understand it's not a problem to install several different version and I have just downloaded both 8.2 DP1  and 9.0.0DP 8

Um... see below.

>      
>      but before diving in… would like to hear from anyone here… on issues with 9.*

I think this will depend on a number of factors, some of which have to 
do with your OS. For me, the last usable version of LC9 is dp6, which is 
dated 8 March, so has no bugfixes or new features in the last six 
months. While dp6 is the version I've standardized on for new work, I 
can't recommend it for anything other than experimenting with new 
features. In particular, extensions are not binary-compatible between 
LC8 and LC9, which means I have two separate folders for user plugins, 
etc. This is more of a pain than it appears, because LC8 and LC9 share 
the same preferences file, so I have to switch preferences from the IDE 
when moving between the two versions.

That said, dp6 seems pretty stable to me, so if you don't mind being six 
months out of date, it's worth a look, especially if you can install it 
on a separate machine or VM. I wouldn't trust production-ready code to 
it, though.

-- 
  Mark Wieder
  ahsoftware at gmail.com





More information about the Use-livecode mailing list