breakpoints being ignored

Ali Lloyd ali.lloyd at
Thu Mar 9 05:58:46 EST 2017

These issues sound like they are to do with Script Debug Mode. Please check
if this is turned on in the Development menu.

Mike, this sounds like it was probably your issue too, especially if
trashing your prefs fixed it, as Script Debug Mode on is the default.

It *does* sound like there may be a new issue with Script Debug Mode
getting turned off somehow, which seems worth looking into.

On Thu, Mar 9, 2017 at 6:29 AM Sannyasin Brahmanathaswami via use-livecode <
use-livecode at> wrote:

> Interesting… this was happening to me today. on a hunch I set the
> gRevDevelopment to true… thinking that because I had messed with that
> yesterday while using the remote debugger on my android phone… I had done
> something that was blocking script debug --  related to the action of
> answering "No" to the dialog asking if you want to run a remoteDebug
> session,  just after installing the standalone on the phone… because I
> thought (have yet to test/reproduce… very tedious…) possibly that is at
> least one action that might toggle script debug mode to off (even though it
> appears checked?) and so your break point could possibly be ignored at that
> point and until you reboot LC?
> Dunno, just was just fishing for possible recipes…
> but aha, gRevDevelopment, true:  the break point was "honored" Of course
> it starting stepping through a lot of IDE code, so I had to go back and set
> the gRevDevelopment to "false"  and now the break points work…
> ….of course if it goes all the way back to 8.1.3 and 6, then it could be
> anything….
> BR
> Mike Kerner wrote:
>     Add a "breakpoint" line as the first line in the script
>     execute again
>     breakpoint still doesn't fire.
> _______________________________________________
> use-livecode mailing list
> use-livecode at
> Please visit this url to subscribe, unsubscribe and manage your
> subscription preferences:

More information about the use-livecode mailing list