AW: AW: load URL is broken in 8.1.4

Tiemo Hollmann TB toolbook at kestner.de
Mon Jul 31 07:55:52 EDT 2017


Hi Mark,
thank you for your explanations. What I can understand are the regressions switching from 6 to 7/8, because of widely new underlying architecture and components. That was a huge step. There I had a lot of sympathy. What is much more harder to understand and acceptable are the regressions within version 8. I would think that there is not such a general exchange of components under the hood from 8.1.4rc1 to 8.1.4, which would make a total test of every detail necessary. My first idea was a bug in tsNet.dll, but this "load URL" bug is not caused by the different versions of tsnet, but definitively by LC 8.1.4.
Tiemo


-----Ursprüngliche Nachricht-----
Von: use-livecode [mailto:use-livecode-bounces at lists.runrev.com] Im Auftrag von Mark Waddingham via use-livecode
Gesendet: Montag, 31. Juli 2017 13:41
An: How to use LiveCode <use-livecode at lists.runrev.com>
Cc: Mark Waddingham <mark at livecode.com>
Betreff: Re: AW: load URL is broken in 8.1.4

I don't think there is anyway we can deny that the transition from 6.x to 7.x caused a lot of regressions.

This is why we have a strict policy of handling maintenance releases now - i.e. we work very hard to ensure each maintenance version is strictly better than before.

I know of a number of users who have had similar difficulties moving from 6 straight to 8 - however, barring the occasional error (e.g. The backdrop fiasco and the load URL one you mention directly) 8.1.(x+1) has had less regressions relative to 6 - and no regressions relative to 8.1.x.

Also (as far as we can) regressions relative to older versions get very high priority in our bug fixing queue.

So things might not yet be perfect but I'd hope that everyone can see that we've made great strides (indeed, we've made good progress on fixing issues which have been around a lot longer recently - even back to the very early days of the MetaCard engine).

No-one likes encountering regressions - however in a system as complex and broad as ours they are often unavoidable.

Every one sees a different view of the elephant so to speak - and we try to act as quickly as we can when issues are reported (usually seeeing them fixed in the next maintenance release).

Warmest Regards,

Mark.

Sent from my iPhone

> On 31 Jul 2017, at 12:27, Tiemo Hollmann TB via use-livecode <use-livecode at lists.runrev.com> wrote:
> 
> I forgot my final question: Have you made similar experiences or is it 
> only me and how do you handle this permanent hazard of regression bugs?
> Tiemo
> 
> -----Ursprüngliche Nachricht-----
> Von: use-livecode [mailto:use-livecode-bounces at lists.runrev.com] Im 
> Auftrag von Tiemo Hollmann TB via use-livecode
> Gesendet: Montag, 31. Juli 2017 11:16
> An: LiveCode User Liste senden <use-livecode at lists.runrev.com>
> Cc: Tiemo Hollmann TB <toolbook at kestner.de>
> Betreff: load URL is broken in 8.1.4
> 
> Hello,
> 
> For my automatic update mechanism I am downloading a zip file from a 
> web server, extracting the zip file and starting the downloaded update.
> 
> I am doing this since years, without having changed anything in my 
> code. Now in 8.1.4, Windows 10 this load URL downloads a 
> "broken/corrupted" empty zip file, which breaks my whole update 
> process. In 8.1.4 rc1 this still has worked and in 8.1.5 it seems to 
> work again without any changes in my code or the zip file. I didn't tested yet 8.1.6 and 9.
> 
> I had done a minor change in my program, completely far off the 
> download handler and just build a new standalone for a new CD 
> production and thought I'll take the "stable" release 8.1.4 instead of 
> the last build with 8.1.4
> rc1 for the new production. Because it was only a minor bug fix in my 
> program and I only switched from 8.1.4 to 8.1.4 rc1 I didn't tested 
> each and every possible feature of my program, before going into the 
> production of a new release. Only by a great chance I discovered that 
> my update process is broken. If I would have sold this new CD 
> production, I would never have been able to update my program again, 
> because the update process would have been broken.
> 
> In all the years working with RunRev/LiveCode I never have experienced 
> so many, frequently regression bugs as in LC 8. I had at least 10-20 
> regression bugs in LC 8, since switching from 6.7. Almost in each 
> single release candidate and each general release there are new 
> regression bugs of old and common features so that it is a game of 
> hazard to use a new release. I have no idea, what is going on behind 
> the scenes in Edinborough, if it is related to the open source 
> development, so that everybody can create regression bugs, but this 
> isn't anymore a reliable software development. The complete responsibility is passed to us.
> 
> Sorry, but I am really pissed off and my trust in every new release 
> has dropped to zero.
> 
> Tiemo
> 
> 
> 
> 
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your 
> subscription
> preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode
> 
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode


_______________________________________________
use-livecode mailing list
use-livecode at lists.runrev.com
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the Use-livecode mailing list