Simulator woes

Paul Hibbert paul at livecode.org
Wed Dec 27 17:11:59 EST 2017


Devin,

I did just see the same error when launching the simulator for the first time (this session), but then I restarted the simulator device and all worked as expected, but it was a long laborious process displaying multiple messages.

One trick I’ve used in the past still worked OK. When the simulator does finally open, add it’s icon to the dock, now when working on a mobile apps, launch the simulator from the dock first, when it does open fully any tests sent to the simulator from LC are opened much quicker

LC 9.0.0 (dp11)
Xcode 9.2
Mac OS Sierra 10.13.2

Paul




> On Dec 27, 2017, at 11:27 AM, Devin Asay via use-livecode <use-livecode at lists.runrev.com> wrote:
> 
> Hi all,
> 
> I’m heading into my annual foray into teaching mobile development, and so testing running stacks in the simulator. For the life of me, I’m unable to get a stack to show up in the simulator, where I’ve had little trouble in the past. Has something changed?
> 
> When I try to test a stack in the simulator I get the “taking a long time to launch” message several times. The simulator does launch. Eventually I see the message “Unable to start simulation: Simulator session timed out.” This happens whether or not the simulator is launched when I hit the Test button in LiveCode.
> 
> I’ve tried several different versions of LC and Xcode. All the same result. Right now I’m on:
> 
> Mac OS 10.12.6
> LiveCode 9.0.0 DP 11
> Xcode 9.2
> 
> Is this a new problem that others are seeing? I’m not finding anything in the forums, and have a vague memory of a discussion here about this topic. Any help greatly appreciated.
> 
> Devin
> 
> 
> Devin Asay
> Director
> Office of Digital Humanities
> Brigham Young University
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode




More information about the Use-livecode mailing list