Simulator woes

Devin Asay devin_asay at byu.edu
Wed Dec 27 14:27:59 EST 2017


Hi all,

I’m heading into my annual foray into teaching mobile development, and so testing running stacks in the simulator. For the life of me, I’m unable to get a stack to show up in the simulator, where I’ve had little trouble in the past. Has something changed?

When I try to test a stack in the simulator I get the “taking a long time to launch” message several times. The simulator does launch. Eventually I see the message “Unable to start simulation: Simulator session timed out.” This happens whether or not the simulator is launched when I hit the Test button in LiveCode.

I’ve tried several different versions of LC and Xcode. All the same result. Right now I’m on:

Mac OS 10.12.6
LiveCode 9.0.0 DP 11
Xcode 9.2

Is this a new problem that others are seeing? I’m not finding anything in the forums, and have a vague memory of a discussion here about this topic. Any help greatly appreciated.

Devin


Devin Asay
Director
Office of Digital Humanities
Brigham Young University



More information about the Use-livecode mailing list