RESTful PUT error

andrew at midwestcoastmedia.com andrew at midwestcoastmedia.com
Fri Dec 15 12:19:10 EST 2017


I tried suggestions from several users (on and off the list), but  
nothing has worked for me. After contacting Pipedrive tech support, I  
got the typical IT response of "it works for us" as they blamed  
LiveCode. They suggested that somehow using regex would fix the issue,  
but I'm not sure how that would even apply here (their API is telling  
me the characters are disallowed, not LC). Using tsNet calls gave me  
the same errors as libURL from LC (8.2dp2 and 9.0dp10).

httpHeaders: {"Accept":"application/json"}
JSON being POSTed (not PUT as their API requests): {"phone":"555-555-5555"}
URL being POSTed to (includes my API key for a test account):  
https://api.pipedrive.com/v1/persons/1?api_token=ce95ed7f11e167194b0b4a6f6f1032df4fa13792

Reply from their support team:
I checked with our engineers regarding the "Disallowed Key Characters"  
message, and they believe this is related to your code editor of  
choice. Some additional programming may be necessary to include these  
"disallowed" characters. They also tested updating the phone value  
themselves via API, and were successful.

For more reference on this issue, they also recommend the following resources:
https://stackoverflow.com/questions/4197976/codeigniter-disallowed-key-characters
http://www.darwinbiler.com/disallowed-key-characters-in-codeigniter/


--Andrew Bell





More information about the Use-livecode mailing list