iOS Home Button Shutdown not working!

Chris Sheffield cmsheffield at icloud.com
Thu May 8 10:44:43 EDT 2014


Rick,

This seems to be working fine for me. Which version of LC are you using? I just did a simple test using a put command and checking console output using LC 6.6.2 RC3. Tested in both the simulator and on a device. My shutdown handler triggers in both cases.

You might try a simple test like that with a put statement right at the beginning of your handler, if you haven’t done so already. If you don’t see any output in the console, then there’s definitely an issue and it should be reported to RunRev. But if you do, then you should be able to do a little debugging and try to figure out exactly where the problem lies.

Chris


--
Chris Sheffield
Read Naturally, Inc.
www.readnaturally.com



On May 7, 2014, at 8:00 PM, Rick Harrison <harrison at all-auctions.com> wrote:

> Hi there,
> 
> I have an iOS app that when the user hits the iPhone “Home” button,
> it doesn’t seem to be sending the “shutdown” message to the
> current card.
> 
> Yes, I also tried “shutdownRequest” and that doesn’t work either.
> 
> I therefore have no way to save the state of the app
> so the user can pick up where he/she left off in the app
> when they decide to come back to it.
> 
> Suggestions?
> 
> Thanks in advance!
> 
> Rick
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode




More information about the Use-livecode mailing list