Unable to open file using shell or process

Glen Bojsza gbojsza at gmail.com
Thu Oct 14 12:07:10 EDT 2010


For all the linux users (or anyone that know shell or process)

In a terminal window I can run the following command line and get the data
generation I need.

This should work in either a shell or process.

First I am the same user as what I do in the terminal window and I am in the
correct directory... even did the complete path!

on mouseUp
put "/home/Bill/Desktop/report/nr.php -f tt.conf " into promysql
   open process promysql for update
   read from process promysql for 500
   put it into fld tout
   write "quit" to process promysql
   close process promysql
end mouseUp

Error: Unable to open tt.conf

I also tried

on mouseUp
put "/home/Bill/Desktop/report/nr.php -f tt.conf " into promysql
put shell(promysql)
end mouseUp

Same error as before: Unable to open tt.conf

As I mentioned I confirmed in the terminal that I was user Bill.

on mouseUp
put shell("whoami")
end mouseUp

shows that I am Bill

Regular linux commands (ie - ls -l or pwd) work both with shell and process.

The file is not locked and I can run it directly in the terminal.
$/home/Bill/Desktop/report/nr.php -f tt.conf


Any suggestions?

thanks,



More information about the Use-livecode mailing list