revVideograbber + Mac OS X 10.6.5 + iSight bug

Ben Rubinstein benr_mc at cogapp.com
Mon Dec 6 13:04:27 EST 2010


Hi Martin,

I've been working with the video grabber recently on OS X 10.6.5, with both LC 
4.0 and 4.5, and haven't come across this.  Our test platforms are all using 
an external camera, but my development was all on MacBook Pro with built-in 
iSight.

If you have a sample app/stack, I'd be happy to test it under 10.6.5 and see 
if I can reproduce the issue here.  I owe RunRev some notes about other VG issues.

Ben

On 06/12/2010 16:23, Martin Koob wrote:
>
> I have had a couple of users of my application report the the video capture
> window (the revVideoGrabber preview) has a green or grey area over the video
> image intermittently.   I tested it on one user's computer and I determined
> that it happened when they had the iSight set as the video source.   I was
> able to try it on their Mac and switched to a DV input and the problem
> disappeared.
>
> The grey or green area is not saved to the video.  I played video captured
> on that Mac on another mac that has an earlier version of Mac OS X and the
> video was fine.
>
> I also noticed that a focused player window with a Quicktime movie in it
> will exhibit the same behavior if the revVideoGrabber preview window is
> open.  The video image in the player will have a grey or green area that
> appears intermittently over the video.
>
> Both users are using Mac OS X 10.6.5.
> The application was compiled with LiveCode 4.0, ( I have not yet compiled a
> release version with 4.5 yet.)
>
> Has anyone else seen this?  If anyone has Mac OS X 10.6.5 could they test
> this to confirm this?
>
> Thanks.
>
> Martin Koob
>





More information about the Use-livecode mailing list