RUNREV Technical support

Dave dave at looktowindward.com
Fri Jan 23 07:26:43 EST 2009


On 23 Jan 2009, at 01:53, Kay C Lan wrote:

> On Fri, Jan 23, 2009 at 6:11 AM, <camm29 at tesco.net> wrote:
>
>>
>> AS A REMINDER :-
>> ALL IS OKAY ON 2.8 WITH STANDALONE PASSWORD SET
>> ALL IS OKAY ON 3.0 WITHOUT STANDALONE PASSWORD SET
>>
>
> All this seems to point towards a problem with Rev 3.0
>
> Can I ask, does this stack actually use any 3.0 features, what is  
> wrong with
> just building it in 2.8, or even 2.9? Why don't you mention 2.9?

Actually, I think there is a problem on 2.8.1.472 which wasn't  
addressed, then either in 2.9 or 3.0 another problem was introduced  
which somehow interacts with the first problem and results in the  
Standalone problem.
>
> Also, as this thread is rather long and I can't remember. What  
> happens when
> you start from scratch, Start Rev 3.0, no other previous work open,  
> build a
> new main stack, add a simple 'hello world' button with answer  
> dialog, then
> save as Standalone with Password set. Does this fail for you?
>
> Grasping at staws:-(

Seem to me that all this effort by all these different people is  
getting us no where fast. The way I would try to get a handle of this  
problem is to add code to the Standalone builder that dumps into a  
log file. Over the years I have found that this is the quickest and  
most reliable way to solve problems like this. However that file is  
protected.

So, why doesn't RunRev provide a version of the Standalone builder  
that dumps a trace to a log file?

Seems like so little effort to do this and it would have save a lot  
of wasted man hours.

All the Best
Dave





More information about the Use-livecode mailing list