2.9 or 2.8.1 – Same problem

Tom Johnson tom.quailcreek at gmail.com
Thu Mar 6 20:25:44 EST 2008


All,
I'm having a pretty server problem when printing. I'm not sure if it's Vista
or my printer, computer, OS combination causing the problem but it nasty. I
have a card with a screen captured image on it and a series of fields and
check boxes that make up a form. The image is a black and white gif that is
only about 65k. I have 33 different form configurations in this app. When I
first started to set up the printing routine for the app. it crashed Rev
every time. So I started removing one field at a time and I got to a point
where it would print. If I add one more field I get a blank page off the
printer. This was with 2.8.1. So I tried it in 2.9, same results. Here's
another thing, when I try to print the script of the app from the script
editor, it kills Rev. When I try to print using one of the exercise/examples
in the "Getting Started Working with Scripts" it crashes Rev. Now here's the
kicker. When I run the exact same print routine I have below on XP, no
problem, it prints just fine.

Thanks
Tom

Here's the configuration I'm running:
Vista Home Premium
Toshiba - Satelite A215
AMD Turion 64 x2 Mobile Technology TL-56 1.80 GHz
1 Gb of RAM
250 Gb HD
Printer - Lexmark, X9350 wit the latest drivers

Here's the print script:
on mouseUp -- script of print button on this card
    set the printscale to .68
    set the printmargins to 18,18,18,18
    set the printpapersize to 612,792 -- 8.5x11 inches, US Letter size
    set the width of this stack to 840
    set the height of this stack to 1083
    hide me -- hide the print button
    open printing
    print this card
    close printing
    set the height of this stack to 700
    set the width of this stack to 882
    show me
end mouseUp



More information about the Use-livecode mailing list