record sound kills USB audio output

Dan Soneson sonesond1 at
Tue Oct 24 12:16:59 EDT 2006

> Yep, this is a weird one. I've had it happen with some USB headphone/
> speaker sets, finally tracked it down to OS X.
> Go to: applications/Utilities/ and double-click 'Audio MIDI Setup'
> In 'Audio Output' change the frequency setting from where it's at, as
> it has been changed (don't ask me why...). Say change it from 44100
> Hz to 32000 Hz and you should have sound pop back.

I don't think this has anything  to do with MIDI. In fact, there is  
no option
for Audio Output in  the "Audio MIDI Setup."

I checked the system with "Amadeus II," a sound editing program, and  
the USB
headset worked fine. I could record and playback through the USB  
headset just
fine. I then checked with a program that I had written in Director,  
using the
Sound Xtra to record. This also worked fine. I could record through  
the microphone
of the headset and hear the audio playback through the headset  

However, as soon as I record something in Revolution, calling the  
"record sound" command,
the headphones on the USB headset go dead. And they are dead for any  
audio in the computer.
The only way to get audio back into the headset is to reboot the  
machine. I can change the
audio out to the built-in speakers in the computer and that plays  
back just fine. I just can't
get the audio to go through the USB headset.

These headsets are Logitech Premium USB Headset 350. I may just have  
to go back to
my Plantronics headsets with the iMic, but they have proven to be not  
very long lasting
with regard to the microphones. I was hoping to find a more robust  
solution. Since this
is a lab classroom, we can't have audio playing through computer  
speakers, and we need
to have audio working.

The problem persists on Intel iMacs, PPC iMacs and my G4 Desktop system.

I'd be grateful for any suggestions.


Dan Soneson
Director, Language Lab
Southern CT State University
New Haven, CT. 06515

More information about the use-livecode mailing list