IDE gone unstable with stack menu change

Chris Sheffield cmsheffield at
Mon Oct 16 17:16:59 EDT 2006


One trick I've learned that keeps the other controls from shifting up  
is to hide your menu group first, and then set as menubar on Mac OS.  
Of course, if this app has to run on Windows as well, you'll have to  
show the menu group via your code if the platform is "Win32".  
Otherwise, no menus. :-) But this has worked for me in the past. I'm  
not sure if this is a "bug" or "undocumented feature" or what, or  
whether or not it will always be possible, but for now it has gotten  
me out of a couple pickles myself.


On Oct 16, 2006, at 2:14 PM, Bill Vlahos wrote:

> I have been happily developing a stack with menus. To make life  
> simpler with the IDE I didn't have them "Set as menubar on Mac OS"  
> in the Menu Builder dialog box. This put the stack menus on the  
> screen but left the IDE menus available for me to use and has  
> worked great up to now.
> I'm about finished with the stack so I checked the box then all  
> hell broke loose.
> 1. Everything shifted up when the menus were removed. I sort of  
> expected this and thought that I could simply move everything down  
> appropriately and get on with life. (BTW it would be nice if it  
> didn't shift everything up.) Perhaps there is a way to avoid this.
> 2. As I start to move things back down, dragging the fields,  
> buttons, etc. sometimes it works but sometimes it leaves trailing  
> images. Also the screen doesn't update itself properly (blank areas  
> where there should be something and/or editing a group shows  
> objects not in the group). These almost always result in the IDE  
> crashing. Sometimes reopening the last saved version of the stack  
> (which looked ok before the save) opens the window much shorter  
> than what it should.
> I'll contact RunRev about this for support but I'm in a pickle on  
> this and was wondering if anyone else has seen this and, even  
> better, has a fix for it.
> I've tried on a different computer thinking my copy of Rev had  
> suddenly gone off but the problem persisted so I think the stack is  
> getting corrupted somehow. Developing on Mac OS X latest version  
> and Rev latest version all Transcript (i.e. no externals etc.).
> Bill Vlahos
> _______________________________________________
> use-revolution mailing list
> use-revolution at
> Please visit this url to subscribe, unsubscribe and manage your  
> subscription preferences:

Chris Sheffield
Read Naturally
The Fluency Company

More information about the Use-livecode mailing list