Terrible RunRev Bug? - Was Weirdness Passing Messages

David Burgun dburgun at dsl.pipex.com
Thu Mar 23 08:55:49 EST 2006


Hi All,

I have a problem that first I thought was something that I was doing  
wrong but now I'm not sure and would like confirmation of how the  
Context mechanism works in RunRev.

I have the following setup:
1  StackMain:Card1:ObjectA:mouseUp   - Calls Function  
StackUtil:PutMessage("MessageX")
2  StackUtil:PutMessage                             - Calls Handler  
StackMain:Card2:ObjectX:MessageX (via send)
3  StackMain:Card2:ObjectX:MessageX - Put "MessageX" into me and then  
Calls Function StackUtil:PutMessage("MessageY")
4  StackUtil:PutMessage                            - Calls Handler  
StackMain:Card2:ObjectY:MessageY (via send)
5  StackMain:Card2:ObjectY:MessageY - Put "MessageY" into me

In this case the "put" statement at step 5 does NOT put "MessageY"  
into  StackMain:Card2:ObjectY (the object is unchanged), but the  
"put" at step 3 works ok.

If I change the code at Step 5 to read:
put "MessageY" into field "FieldY" of group "Y" of card 2 of stack "/ 
Documents/Test/StackMain.rev" (e.g. the hard coded name of the object).

or

local myData
put "MessageY" into myData
do "put myData into " & the long name of me

Then the put statement works ok.

This also works ok:
1  StackMain:Card2:ObjectX:mouseUp   - Calls Function  
StackUtil:PutMessage("MessageY")
2  StackUtil:PutMessage                             - Calls Handler  
StackMain:Card2:ObjectY:MessageY (via send)
3  StackMain:Card2:ObjectY:MessageY - Put "MessageY" into me

I have also tried the following with no luck:

set the text of me to "ObjectY"

What could be going wrong here?
Is it that I am mixing functions and handlers?
How can I test to see if the context is the problem?
I really need to refer to the object without hardcoding it's name  
into the Script, I thought that was what "me" was for?????
Is this a bug? If so is there a workaround??
Can anyone shed some light on this? Any ideas on how to get this  
working would be greatly appreciated.

Mark Smith (many thanks Mark) verified that he has the same problem  
but is using the same platform, could someone try this on Windows or  
Unix? This appears to happen on RunRev 2.6.6 and 2.7. This has made  
be REALLY worried about the usage of "me" and in using RunRev in  
general. I can't believe that something as fundamental as the usage  
of "me" doesn't work 100% of the time. I don't have previous versions  
of RunRev in order to check if it *ever* worked.

Thanks a lot
All the Best
Dave




More information about the Use-livecode mailing list