Transcript language design

Barry Levine themacguy at macosx.com
Wed Jun 9 23:59:07 EDT 2004


Alex,

I'm only going to address the first item; others here will have plenty 
to say about the remaining items.

I have learned to use quotes whenever possible in order to assist Rev 
to determine what I want it to do.
To use your example:

put "something" into field "field 1"

...leaves no room for doubt.

I also try to rename my objects to indicate their intended purpose. 
Fields might be named: "textData" or "numData" or "theFirstName". 
Again, note the quotes and also note the practice of using capitals in 
the appropriate places to assist recognition. If you also use "smart 
names" for your variables you'll end up with transcript statements like 
this:

put userEnteredName into field "theUserName"

which tells you where you've been and where you're going, so to speak.

I wrote my first programs in Business Basic and Commodore Basic. I 
moved to HyperCard and learned enough in two weeks to become 
productive. I'm not that smart; HyperTalk and Transcript share, among 
other things, three traits that I treasure: An extremely high level 
syntax about as close to plain English as you could wish, the 
availability of long object names, and the ability to deal with 
synonyms. This latter trait drives "traditional" programmers nuts. 
*grin*

Regards,
Barry

On Jun 9, 2004, at 5:05 PM, Alex wrote:

> From: Alex Tweedly <alex at tweedly.net>
> Subject: Transcript language design.
> To: How to use Revolution <use-revolution at lists.runrev.com>
> Message-ID: <5.1.0.14.0.20040609233118.023549e0 at pop3.btinternet.com>
> Content-Type: text/plain; charset="us-ascii"
>
>
> One of the things that is a bit of a hurdle for a "traditional language
> programmer" (like me) to overcome is the unusual syntax and verbosity 
> of
> Transcript. I'm trying to convince myself that this will feel more 
> natural
> if I just keep trying :-)
>
> Are there any "style" hints or suggestions to help with this ?
>
> I've spent today making "simple" changes to the tutorial scripts; the 
> three
> issues that have occupied an embarrassingly large number of hours today
> have been
>
> 1.  Simple script.
>      put "something" into field1
> Of course, what I meant was
>      put "something" into field field1
> so it was disappearing into an unintended local variable.



More information about the use-livecode mailing list