Kudos for RunRev

MisterX b.xavier at internet.lu
Sun Dec 19 02:08:39 EST 2004

While sometimes I do rant hard, I do also sometimes jump and yell and
applaud RunRev for the excellence in RunRev file handling. Check this event

Here i was trying to casually improve my GTR file browser (with image,
sound, pdf, etc preview editing or launching respectively) and writing a
settings modifications manager for the many different combinations of cars,
tracks, event type, engine, gearbox, suspensions, tyres and the rest that
could come into a game or racing event (including weather, pit stops
strategies, tyre wear, down to chat strings groups). This is not a game,
it's a car OS! ;)) If you like GT cars, buy this game!

Indentally I clicked on the wrong line of the file list which creates a
preview of the file into a field. It was the Audiodata.dat which is a 132MBs
of recorded car sounds (very realistic!), pit announcements, radio com, etc!
So the script dumps the file into the field... it's a one liner (put url
thefile into fld "preview")

RunRev freezes, the HD light is overheating the plasma relays, the pc is
vibrating energitically, windows slows down to a snail-in-alaska speed! The
browser is dumping all of 132 Megs of binary data into the preview field!

But after 32 seconds, it was ready back to normal! RunRev goobles 511Megs of
RAM! I clicked on another file quickly and it displayed it's html no prob!
Another 32 seconds wait! Revo is back to a normal 13MBs of RAM after that!
Tried it again, 14 MBs, save, 15 MBs, choose another file 16MBs. Tried a
couple more saves and opens and the ram was stable.

Excellent programming - Im officially impressed! It's solid and I give it my
Xfactor rating! Everyone should apply that kind of programming as a

A warning of file size and an option to page it will be nice to have in the
future too...

One question, how can you tell a file should be read as a binfile? It's
possible a binfile may not contain zero ascii characters but anything can be
considered ascii too...

Merry seasons and a revolutionary 2005
PS: oops! Revo crashed AFTER i closed the stack and clicked on the
revmenubar again. Is there a bugzilla for this yet?

More information about the use-livecode mailing list