2.0r1 BUG in Replicate

Jim Witte jswitte at bloomington.in.us
Thu May 15 00:21:02 EDT 2003

> Rev 2.0r1 still doesn't replicate groups of objects properly.
> Try:
> Result: one button in each resulting group is messed up in size and 
> position.

   I'm using OS X 10.2.3, and it works (or more accurately, doesn't 
work) for me too, using Rev 2.0r1.  I've included a demonstration stack 
(won't bounce to the list probably).  Here's a lot of data about the 
problem to chew on: The original three buttons are named Button [1-3].  
I used 5 replications with an offset of 30.60.  The resulting offsets 
for all the replicated groups are almost the same; they are: 32,26; 
32,32; 32,32; and 32,32. (I didn't change the group margins)

   As can be seen in the stack, the replications of "Button 3" are 
larger, and cover the replications of buttons 1 and 2.  The 
replications of buttons 1 and 2 appear to be created in almost the same 
spot, so each of the replicated groups is bigger than the last, even 
though the have almost the same topleft.  Button 3 is also the only 
button ever labeled with the number of the replication (eg Button 3 1, 
Button 3 2, etc)

   But if I select the objects separately, the command appears to work 
properly, even if the objects are grouped (but if they are, all the 
replicated objects are put in the original group of course)

   I tried creating just a single button and putting it along into a 
group, and the offsets looked alright (not exactly the same, but 
certainly not as wrong as the first experiment)  But the replicated 
buttons were bigger than the original: the original's size 
(width,height) was 31,90; while all the copies were 39,98.

   But if I did this second experiment again and set all the margins to 
0, the size didn't change, and the offsets looked exact.  I tried 
setting the margins to zero on a group of multiple objects, but it 
didn't correct the replication problem.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: Replicate Problem.rev
Type: application/octet-stream
Size: 2899 bytes
Desc: not available
URL: <http://lists.runrev.com/pipermail/use-livecode/attachments/20030515/2a6443b7/attachment.obj>
-------------- next part --------------

More information about the use-livecode mailing list