Valentina and OS-X (Darwin) revisited...

Greg Saylor gsaylor at net-virtual.com
Wed Nov 20 04:48:01 EST 2002


Hello,

A long time ago (8 months or so) I had posted about using Valentina under
OS-X Darwin...   Unfortunately the lack of this ability has held up my
project for over a year now - and this was only discovered after having
purchased Revolution...  So Revolution has basically been a complete bust
for me due to this issue... ;-(   I even convinced one of my clients to
purchase a license as well, but thankfully the mistake of purchasing it
for use as a database application was one that I made on my own dime and
not my client's...  

I just tried the revdb under Darwin and it doesn't work either:

#!Darwin

on startUp
        get revdb_connect("Valentina","","faa.vdb")                
        put "Hello WOrld!" into tresponse
        put tresponse
end startUp


NOTE: If I comment out the "get revdb_connect" line this script does what
is expected (it prints "Hello World!" to the console)...  If I don't I
get the following result:

[host100:Revolution 1.1.1/components/engines] root# ./test
Darwin exiting on signal 10
[host100:Revolution 1.1.1/components/engines] root#


What this all comes down to is that I have to get this project start --
which should have been finished by now.. And my Revolution license which
has been doing nothing but collecting dust is coming up for renewal...

Is it possible to either use Valentina with the Darwin engine or at least
to get the OS-X engine to function correctly from the command line?  

It remains baffling to me that the developers of these respective
products have not yet integrated their products to work together at the
command-line...  Practically every database product worth any amount of
salt has the ability to manipulate the data using command-line tools...

It is enough of a burden to have to learn this new transcript language
and development environment which is extremely inefficient (at least to
me)...  I like to have vi open in one window and execute my scripts from
another window.. The fact that I have to keep draggin' a mouse all over
the screen just to get something to work is simply a distraction -
especially when trying to conceptualize some process which should operate
entirely automated without any human interaction....

Sorry if I sound bitter, but I am... I have never bought a product before
that I was so excited about and after almost a year still been unable to
realize any value from it....

Thanks for listening to me gripe!

- Greg

P.S. THe "windowless OS-X" as well as writing Applescript junk to speak
to the OS-X engine are not acceptable options here either... I have found
both to be unreliable and clumsy to script automated processes with - if
they would even work for this anyways....

P.S.S. I have also tried:

#!/usr/bin/open ~/Revolution/components/engines/MacOSPPC

on startUp
        put "Hello WOrld!" into tresponse
        put tresponse
end startUp


However, the MacOSPPC engine does not seem to accept "scripts" because it
just starts up the development environment instead of executing the
code.....  (THis would probably be the best solution - to make the
MacOSPPC engine work like a UNIX engine when called from a command-line
script, if possible)...


P.S.S.S. I have tried lots of other stuff too - this just doesn't seem to
work but I can't remember everything I tried....




More information about the Use-livecode mailing list