sound recording to AIFF file

cowhead at cowhead at
Thu Aug 29 13:24:01 EDT 2002

If it sounds fine in quicktime/moviePlayer then the recording is 
apparently fine.  It is playing you are having problems with.  Have 
tried starting with a player, then setting the fileName of player 
"myPlayer" to your sound file?  Using this technique, can you play any 
other sound files recorded with other programs?  Try playing an MP3 file 
this way.  If that doesn't work, there is something wrong with your Rev.
Here is quick script that works on multiple machines, using Mac OS 
10.1.5 and QT6:

on mouseUp
   answer file "what?"
   put it into myFile
   create player "myPlayer"
   set the showController of player myPlayer to true
   set the fileName of player myPlayer to myFile
   start player myPlayer
end mouseUp

mark mitchell

Carsten wrote:

> But when recording:
> "record sound file "sounds/myOwnSound" with best quality"
> The file is correctly created in the folder etc. etc.
> It is a fine QuickTime sound file that plays splendid in 
> movieplayer ... but
> when using:
> "play audioclip "sounds/myOwnSound""from within Revolution it sounds 
> awfull,
> to put it gently.
> tried "play "sounds/myOwnSound"" ... not any better.

More information about the Use-livecode mailing list