Sound recording to aif file - support request

Carsten Levin carstenlist at
Thu Aug 29 11:36:01 EDT 2002

With Rev 1.1 we tried using the recording, and it didnt work under Mac OS X.
Now we are trying again with Revolution 1.1.1 and Mac OS X 10.2 running
QuickTime 6. And we are still having the same old problems.

We need to be able to record .aif files stored in folders with our
Revolution solutions. Untill now we have succesfully used the "recordsound"
But this external doesnt work with Mac OS X and Windows, and the new (rev
1.1) internal recording is easyer to controll using scripts.

But when recording:
"record sound file "sounds/myOwnSound" with best quality"
The file is correctly created in the folder etc. etc.
It is a fine QuickTime sound file that plays splendid in movieplayer ... but
when using:
"play audioclip "sounds/myOwnSound""from within Revolution it sounds awfull,
to put it gently.
tried "play "sounds/myOwnSound"" ... not any better.

To make sure that we did everything correctly I copied the scriptline from
the Transscript dictionary and only modified the finer details.

Also tried with "as codec" ... MAC3, and some of the other suggested
options. Same result - or if possible ... worse.

Whats wrong with our script ... or with the Revolution documentation?

Best regards

Carsten Levin

More information about the Use-livecode mailing list