Trying to run standalone (headless) on Linux (Ubuntu) - failed at first hurdle

Ben Rubinstein benr_mc at
Thu Mar 10 09:48:48 EST 2022

I'm trying to develop an app which will run headless on Linux (actually in a 
docker container). I've done this before... so long ago that I can't 
remember... with an earlier version of this app. Normally I run this on Mac 
and Windows.

So (under LiveCode 9.6.6) I simply checked the Linux 64 option in the 
Standalone builder, built the app, transported the folder with the binary 
"MyApp", "Externals" folder, and "" to the Docker container, and 
tried to launch it:

> # ./MyApp -ui
> ./MyApp: error while loading shared libraries: cannot open shared object file: No such file or directory

Can anyone point me in the right direction here? Does this mean that I need to 
do something different in how I build the app, or install something different 
in the environment?

(The container is running Ubuntu 18.04.2 LTS).



More information about the use-livecode mailing list