The Dreaded tsNet "Error Previous request not completed" iOS app

J. Landman Gay jacque at
Wed Nov 17 14:43:46 EST 2021

On 11/16/21 6:51 PM, Ralph DiMola via use-livecode wrote:
> iOS app built with LC 9.6.5 rc2 on Big Sur using Xcode 12.5.
> I am doing several synchronous operations in the form "put url (some-url)
> into tVar". I do 1 or 2 and then every request after that fails.  Played
> with the various timeouts with no success. I also tried setting
> tsNetLibUrlReuseConnection to false. This code worked in previous versions
> of LC. Fails on iPad but works in the IDE. Has anyone seen this? I have a
> little bit of a time crunch. Any suggestions would be appreciated.

I asked about the same thing a month ago. Here's the reply by Charles Warwick:

The essence is:
"In order to fix this, you can use tsNet's asynchronous commands (e.g.  tsNetGet instead of 
tsNetGetSync, tsNetPost instead of tsNetPostSync, ...) or libURL's "load URL" command.  The 
"load URL" command only support HTTP GET requests which means that if you need to use other 
types of requests (e.g. POST) then use the tsNet functions directly."

Rather than rewrite all my scripts I settled for a short wait between requests.

Jacqueline Landman Gay         |     jacque at
HyperActive Software           |

More information about the use-livecode mailing list