Android Studio 3.6 breaks LC Android deployment?

Paul Richards paul at
Fri Mar 20 08:29:58 EDT 2020

Hi Devin, 

I had the exact same issue, but on Windows.  Having spent many days on this, your solution worked - Thank you or sharing.  I could not setup Livecode with a clean install of Android Studio 3.6, but having deleted it and  installed v3.5 - Livecode worked straightway and I was then able to update Studio to v3.6.


-----Original Message-----
From: use-livecode <use-livecode-bounces at> On Behalf Of Devin Asay via use-livecode
Sent: 19 March 2020 22:04
To: How to use LiveCode <use-livecode at>
Cc: Devin Asay <devin_asay at>
Subject: Android Studio 3.6 breaks LC Android deployment?

Hi all,

Yesterday I had to install Android mobile tools on my laptop (since I’m having to work from home now. I downloaded the newest JDK 1.8 and the newest Android Studio (v. 3.6). (LC v. 9.5.1 on Mac 10.14.6).  I spent a frustrating afternoon of getting an error every time I tried to specify the Android SKD root in LC Mobile Support preferences. Message was "The chosen folder is not a valid Android SDK. Please ensure you have installed it correctly, and enabled support for 9.0 (API 28)”. Finally after installing and reinstalling everything several times, I decided to drop back to Android Studio v. 3.5.3. Suddenly it was working again!

Details on the forums here:

It seems like Android Studio 3.6 breaks Android deployment in LC. Before I submit a bug report, I wondered if anyone else has seen this problem?


Devin Asay
Office of Digital Humanities
Brigham Young University

use-livecode mailing list
use-livecode at
Please visit this url to subscribe, unsubscribe and manage your subscription preferences:

More information about the use-livecode mailing list