tsNet and Digest Authentication - some problems or better said: missing knowledge

Matthias Rebbe matthias_livecode_150811 at m-r-d.de
Tue Mar 13 14:20:37 CET 2018


Hi Charles,

yes, you are right. For testing i am using the same URL request. But this shouldn´t matter.

I´ve tried LC 9DP11 and LC 8.1.9 Business which both have tsNet 1.3.4 included.

I ´ve filed a bug now.
http://quality.livecode.com/show_bug.cgi?id=21062 <http://quality.livecode.com/show_bug.cgi?id=21062>

Regards,

Matthias

Matthias Rebbe
Tel +49 5741 310000
‌https://matthiasrebbe.eu <https://matthiasrebbe.eu/>‌

> Am 13.03.2018 um 08:55 schrieb Charles Warwick via use-livecode <use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>>:
> 
> Hi Matthias,
> 
> It looks to me that you are issuing a put URL request to the same URL each time?  Are you using the latest version of LC?
> 
> I think I know what is going on, but will need to generate a new tsNet build and get you to test to see if it resolves the issue.
> 
> Can you please raise a bug report and I will follow up there.
> 
> Regards,
> 
> Charles
> 
>> On 9 Mar 2018, at 6:10 pm, Matthias Rebbe via use-livecode <use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>> wrote:
>> 
>> Hi Charles, 
>> thanks for your answer.
>> 
>> I´ve done as requested. 
>> With tsNetLibUrlReuseConnection set to true
>> A session cookie is sent from the PABX after the first successful connection.
>> The 2nd unsuccessful connection shows
>> 
>> "HTTP/1.1 401 Unauthorized
>> Authentication problem. Ignoring this.”
>> 
>> And the value for nonce is an other then the one in the first connection.
>> 
>> After a restart of LC i set  it to false.
>> The error messages looks similar, but i can see also
>> "Issue another request to this URL: 'http://sub-admin:feierabend@192.168.1.1/app_group_logchange?grpId=2641&kommend=0 <http://sub-admin:feierabend@192.168.1.1/app_group_logchange?grpId=2641&kommend=0> <http://sub-admin:feierabend@192.168.1.1/app_group_logchange?grpId=2641&kommend=0 <http://sub-admin:feierabend@192.168.1.1/app_group_logchange?grpId=2641&kommend=0>>'
>> Hostname 192.168.1.1 was found in DNS cache”
>> 
>> 
>> I´ve uploaded the complete debug files here:
>> 
>> https://dl.qck.nu//?dl=liburl_reuse_false.txt <https://dl.qck.nu//?dl=liburl_reuse_false.txt> <https://dl.qck.nu//?dl=liburl_reuse_false.txt <https://dl.qck.nu//?dl=liburl_reuse_false.txt>>
>> https://dl.qck.nu//?dl=LIBUURL_resue_true.txt <https://dl.qck.nu//?dl=LIBUURL_resue_true.txt> <https://dl.qck.nu//?dl=LIBUURL_resue_true.txt <https://dl.qck.nu//?dl=LIBUURL_resue_true.txt>>
>> 
>> Regards,
>> Matthias
>> 
>> Matthias Rebbe
>> Tel +49 5741 310000
>>https://matthiasrebbe.eu <https://matthiasrebbe.eu/> <https://matthiasrebbe.eu/ <https://matthiasrebbe.eu/>>‌
>> 
>>> Am 09.03.2018 um 04:18 schrieb Charles Warwick via use-livecode <use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com> <mailto:use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>>>:
>>> 
>>> Hi Matthias,
>>> 
>>> That does sound strange.
>>> 
>>> If you download the following stack:
>>> 
>>> https://downloads.techstrategies.com.au/tsnet/debug_liburl.livecode <https://downloads.techstrategies.com.au/tsnet/debug_liburl.livecode> <https://downloads.techstrategies.com.au/tsnet/debug_liburl.livecode <https://downloads.techstrategies.com.au/tsnet/debug_liburl.livecode>>
>>> 
>>> Open that stack at the same time as you have your application stack open in the IDE, click the “Start Debug” button, and try your PUT requests.
>>> 
>>> That will display some debug information that might help us work out what is going on.
>>> 
>>> On a related note, ‘tsNetLibUrlReuseConnection false’ should create a fresh connection to the server for the 2nd request, so debug with and without that set would be useful.
>>> 
>>> Regards,
>>> 
>>> Charles
>>> 
>>>> On 8 Mar 2018, at 9:28 pm, Matthias Rebbe via use-livecode <use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com> <mailto:use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>>> wrote:
>>>> 
>>>> Hi,
>>>> 
>>>> i am trying to use the tsNet external to communicate with an Auerswald PABX which requires digest authentication.
>>>> 
>>>> The first connection is always successful  using  PUT URL …..
>>>> The second one isn´t. There is even no value returned.
>>>> When i use tsNetClose and tsNetInit before the 2nd connection then the 2nd connection is successful, because the complete authentication process is initiated from the beginning.
>>>> So this works so far
>>>> —>
>>>> tsnetClose
>>>> tsNetInit
>>>> put URL “http:…..”
>>>> 
>>>> But how can i use the already established connection? tsNetLibUrlReuseConnection FALSE does not help. 
>>>> Is it possible that i have to set the httpheader somehow for the 2nd connection?
>>>> I am not very happy to unload and reload the external every time.
>>>> 
>>>> I also tried to use tsNetGetSync. The first connection is also always successful, the 2nd not.
>>>> 
>>>> So what am i missing?
>>>> 
>>>> Regards,
>>>> 
>>>> Matthias
>>>> 
>>>> 
>>>> 
>>>> Tel +49 5741 310000
>>>>https://matthiasrebbe.eu <https://matthiasrebbe.eu/> <https://matthiasrebbe.eu/ <https://matthiasrebbe.eu/>> <https://matthiasrebbe.eu/ <https://matthiasrebbe.eu/> <https://matthiasrebbe.eu/ <https://matthiasrebbe.eu/>>>‌
>>>> 
>>>> 
>>>> 
>>>> Matthias Rebbe
>>>> Tel +49 5741 310000
>>>>https://matthiasrebbe.eu <https://matthiasrebbe.eu/> <https://matthiasrebbe.eu/ <https://matthiasrebbe.eu/>> <https://matthiasrebbe.eu/ <https://matthiasrebbe.eu/> <https://matthiasrebbe.eu/ <https://matthiasrebbe.eu/>>>‌
>>>> 
>>>> _______________________________________________
>>>> use-livecode mailing list
>>>> use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com> <mailto:use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>>
>>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>>> http://lists.runrev.com/mailman/listinfo/use-livecode <http://lists.runrev.com/mailman/listinfo/use-livecode> <http://lists.runrev.com/mailman/listinfo/use-livecode <http://lists.runrev.com/mailman/listinfo/use-livecode>>
>>> 
>>> 
>>> _______________________________________________
>>> use-livecode mailing list
>>> use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com> <mailto:use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>>
>>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-livecode <http://lists.runrev.com/mailman/listinfo/use-livecode> <http://lists.runrev.com/mailman/listinfo/use-livecode <http://lists.runrev.com/mailman/listinfo/use-livecode>>
>> 
>> 
>> Matthias Rebbe
>> Tel +49 5741 310000
>>https://matthiasrebbe.eu <https://matthiasrebbe.eu/> <https://matthiasrebbe.eu/ <https://matthiasrebbe.eu/>>‌
>> 
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>
>> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
> 
> 
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com <mailto:use-livecode at lists.runrev.com>
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode



More information about the use-livecode mailing list