LiveCode Server on CentOS 6?

Richard Gaskin ambassador at fourthworld.com
Sun Jul 29 20:56:26 EDT 2018


Keith Clarke wrote:

 > Thanks Warren (& Richard) - this probably is the blocker, as this
 > particular VPS is definitely running 2.12
 >
 > Google suggests that I can’t (or at least shouldn't attempt to)
 > upgrade CentOS 6 with a later glibc version, given its central role.
 >
 > Apparently there are workarounds to install an additional, later
 > version of glibc - as an option, alongside the OS version - in such a
 > way that it gets called session by session, when needed (i.e. for LC
 > Server use). However, after failing to complete a couple of these,
 > it's clear but that this is way beyond my Linux chops to sort.
 >
 > So, it looks like server migration / rebuild will need to be on the
 > critical path or it’s a dead-end for experimenting with LC Server for
 > this particular project.

First question (an admittedly ignorant one, but I haven't spent much 
time in the CentOS community):  Why does their package manager not 
automatically keep system components current?

Second question: If the first question cannot be resolved easily, what 
is the advantage of CentOS for this project over Ubuntu or Debian?

-- 
  Richard Gaskin
  Fourth World Systems
  Software Design and Development for the Desktop, Mobile, and the Web
  ____________________________________________________________________
  Ambassador at FourthWorld.com                http://www.FourthWorld.com




More information about the Use-livecode mailing list