set the filename of image bug?

Stephen MacLean smaclean at madmansoft.com
Sun Jul 29 20:01:57 CEST 2018


Still more weirdness:

I removed the old sub-stack from my main stack, renamed it, saved it, quit LC and now it works fine.

Still, in the meantime, I’m rebuilding it from scratch and leaving outside the main stack, loading it as needed. If that goes well, I’ll do that for all my library stacks.

So I’m at a total loss here, nothing really to send now, I’m just scratching my head. I’ll play around with all this a bit more and see if I can re-create it. Otherwise I’ll just have to chalk it up some LC weirdness that I can’t reproduce.

Thanks again!

Steve

> On Jul 29, 2018, at 1:28 PM, Mike Bonner via use-livecode <use-livecode at lists.runrev.com> wrote:
> 
> If you think the stack is corrupted, you might send it to
> support at livecode.com so they can look at it, and/or post a bug report and
> include the stack there so that it can be looked at. (assuming there is
> nothing sensitive in the stack)
> 
> On Sun, Jul 29, 2018 at 11:24 AM Stephen MacLean via use-livecode <
> use-livecode at lists.runrev.com> wrote:
> 
>> Some other weirdness i’m noticing… When I copied a new image to that card,
>> it gave it a very high numbered ID that corresponded with one of the icons
>> in the image library.
>> 
>> I think I’m dealing with some kind of corruption here.
>> 
>> I’m going to rebuild this and give that a try. Thankfully it’s mostly
>> script with just a few cards and graphics for doing things.
>> 
>>> On Jul 29, 2018, at 1:03 PM, Stephen MacLean via use-livecode <
>> use-livecode at lists.runrev.com> wrote:
>>> 
>>> Ok, very strange… I created a test project to run in both 9.0.1 RC1 and
>> 9.0.0… and it works fine, yet doesn’t work in the image that I have in my
>> engine stack in either version.
>>> 
>>> Even renaming the old one and dragging a new image out and trying that
>> doesn’t work. Ugh!
>>> 
>>> I’m at a loss.
>>> 
>>> I’m running business in case that matters.
>>> 
>>> Thanks,
>>> 
>>> Steve
>>> 
>>>> On Jul 29, 2018, at 12:38 PM, Stephen MacLean via use-livecode <
>> use-livecode at lists.runrev.com> wrote:
>>>> 
>>>> HI Klaus,
>>>> 
>>>> Wow, ok… I will have to check 9.0.0. Currently using 9.0.1 RC1 on
>> 10.12.6. It fails for me in both script and the inspector.
>>>> 
>>>> Thanks for testing!
>>>> 
>>>> Best,
>>>> 
>>>> Steve
>>>> 
>>>>> On Jul 29, 2018, at 12:34 PM, Klaus major-k via use-livecode <
>> use-livecode at lists.runrev.com> wrote:
>>>>> 
>>>>> Hi Steve,
>>>>> 
>>>>>> Am 29.07.2018 um 18:28 schrieb Stephen MacLean via use-livecode <
>> use-livecode at lists.runrev.com>:
>>>>>> 
>>>>>> Hi All,
>>>>>> 
>>>>>> I’m having an issue with the “set the filename of img”.
>>>>>> This line: set the filename of img "checkImg" of cd "cropImg" stack
>> "imgEngine" to imgURL
>>>>>> Works as expected when using “http”. When using “https”, it fails to
>> get the image. No error is returned, but the image is blank.
>>>>>> 
>> https://pixfeeds.com/images/usa-travel/1280-589451788-statue-of-liberty-full-base.jpg
>> <
>> https://pixfeeds.com/images/usa-travel/1280-589451788-statue-of-liberty-full-base.jpg>
>> is the test image I’m using. Don’t see any reports of issues, but wanted to
>> know if anyone else has run into this.
>>>>> 
>>>>> just tested, works right out of the box in the IDE, by setting the
>> filename in the inspector and also via script!
>>>>> macOS 10.13.6, LC 9
>>>>> 
>>>>>> Thanks,
>>>>>> 
>>>>>> Steve MacLean
>>>>> 
>>>>> Best
>>>>> 
>>>>> Klaus
>>>>> 
>>>>> --
>>>>> Klaus Major
>>>>> http://www.major-k.de
>>>>> klaus at major-k.de
>>>>> 
>>>>> 
>>>>> _______________________________________________
>>>>> use-livecode mailing list
>>>>> use-livecode at lists.runrev.com
>>>>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>>>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>> 
>>>> 
>>>> 
>>>> _______________________________________________
>>>> use-livecode mailing list
>>>> use-livecode at lists.runrev.com
>>>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>> 
>>> 
>>> 
>>> _______________________________________________
>>> use-livecode mailing list
>>> use-livecode at lists.runrev.com
>>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>> 
>> 
>> 
>> _______________________________________________
>> use-livecode mailing list
>> use-livecode at lists.runrev.com
>> Please visit this url to subscribe, unsubscribe and manage your
>> subscription preferences:
>> http://lists.runrev.com/mailman/listinfo/use-livecode
> _______________________________________________
> use-livecode mailing list
> use-livecode at lists.runrev.com
> Please visit this url to subscribe, unsubscribe and manage your subscription preferences:
> http://lists.runrev.com/mailman/listinfo/use-livecode





More information about the use-livecode mailing list