The coming of SVG

Dave Kilroy dave at
Sun Nov 5 10:46:04 EST 2017

Hmm tricky this naming business isn’t it!

My take on this is that it would be better to have a modifier for an existing control name rather than baptise a new control name to join what we already have (especially as it sounds like what Mark has done to to create a ‘superImage’ / ‘superGraphic’ control (I know there is more to it than that, but for me this is what stands out as new)

In much the same way that ‘trueWord’ joined ‘word’ we could have ‘uniImage’ or ‘trueImage’ (or ‘uniGraphic’ or ‘trueGraphic’) - this will keep the number of control names down as a low as possible and won’t break anything in old code

Kind regards


More information about the use-livecode mailing list