Writing Extensions

Mark Wieder ahsoftware at sonic.net
Thu May 18 18:18:46 CEST 2017


On 05/18/2017 12:30 AM, Mark Waddingham via use-livecode wrote:
> Unfortunately we aren't going to be guaranteeing binary-level
> compatibility of the LCB module format for quite some time - it will
> likely change in every major version for quite a while yet.

That's unfortunate. It means that, aside from distributing the widget 
source code, compiled widgets are bound to a specific LC version with no 
guarantee that they will work with any other past or future version. 
Does 'major version' here mean 9.x or 9.0.x? Can I assume that the 
binary format will stay the same across all LC9.x releases?

I have to say I'm surprised that we're still at this state of things so 
far after the fanfare introduction of extensions.

-- 
  Mark Wieder
  ahsoftware at gmail.com



More information about the use-livecode mailing list