WannaCry [OT]

Richard Gaskin ambassador at fourthworld.com
Mon May 15 12:28:43 EDT 2017


Mike Kerner wrote:

 > Unfortunately, there are very expensive pieces of gear that have
 > controls on them that for one reason or another cannot be controlled
 > by OS's newer than XP.  I happen to have one, here.  It cost
 > $750,000.  There is no dealing with the OS issue without replacing
 > the control, and that is also extremely expensive, on the order of
 > $400,000, so you would not replace the control without replacing the
 > whole unit.  M$, when they decided to dump the XP paradigm, just like
 > when they got rid of DOS, broke upgradability for ATM's, machine
 > tools and CMM's, X-Ray and MRI machines, PBX's, etc.

All systems eventually reach end-of-life.  If a vendor has enough 
technical expertise to deliver hardware worth $750k, it seems reasonable 
to expect that expertise would include sufficient familiarity with 
system life cycles to anticipate a need for modular upgrades.

-- 
  Richard Gaskin
  Fourth World Systems
  Software Design and Development for the Desktop, Mobile, and the Web
  ____________________________________________________________________
  Ambassador at FourthWorld.com                http://www.FourthWorld.com




More information about the Use-livecode mailing list