Android Setup Config

panagiotis merakos merakosp at gmail.com
Fri May 12 14:03:38 EDT 2017


Hi Dan,


I have download the “tools_r24.4.1-macosx.zip” and unzipped it into a
folder android-sdk. Then launched tools/android and installed “Android
4.0.3 (API 15)”.


Now when I launch tools/android I see at the top:

(These are the installed versions)


Android SDK Tools: 24.4.1

Android SDK Platform-tools: 25.0.5

Android SDK Build-tools: 25.0.3


Moreover, my android-sdk folder contains those folders:


add-ons

build-tools

platform-tools

platforms

sources

system-images

temp

tools


And the “platforms” folder contains a folder “android-15”


I can successfully set the “Location of Android development SDK root” in
the LC Prefs, and also to create an android standalone.


Hope this helps,

Panos

—

On Fri, May 12, 2017 at 7:00 PM, panagiotis merakos <merakosp at gmail.com>
wrote:

> Hmm your /MacintoshHD/android-sdk/ directory should also include a folder
> "build-tools". Since it is not present, you can install it using the SDK
> Manager:
>
> Launch tools/android
> Find an item "Android SDK Build-tools" (should be at the top)
> Tick the checkbox and select "Install packages"
>
> After that the problem should be fixed :)
>
> Best,
> Panos
> --
>
> On Fri, May 12, 2017 at 6:34 PM, panagiotis merakos <merakosp at gmail.com>
> wrote:
>
>> Hi Dan,
>>
>> Your setup sounds perfectly fine to me. Could you please check if there
>> is a file /tools/lib/sdklib.jar?
>>
>> In the meanwhile I will check the version of the Android SDK Tools I have
>> installed in my Mac which works OK with LC.
>>
>> Best,
>> Panos
>> --
>>
>> On Fri, May 12, 2017 at 6:06 PM, Dan Friedman via use-livecode <
>> use-livecode at lists.runrev.com> wrote:
>>
>>> Panos,
>>>
>>> Thanks again for the help, but I think I must be stupid.  I selected
>>> “Desktop” and still got “invalid Android SDK”.   So, I deleted everything,
>>> redownloaded “tools_r24.4.1-macosx.zip” and put it in it’s own folder at:
>>> /MacintoshHD/android-sdk/.  I then unzipped it and launched
>>> /MacintoshHD/android-sdk/tools/android.   I selected “Android 4.0.3
>>> (API 15)” and clicked “Install Packages”.   When the install was complete,
>>> I went back to LC 8.1.3 and in Preferences I selected
>>> /MacintoshHD/android-sdk/ as the “Location of Android development SDK
>>> root”.  Once again, “invalid Android SDK”.
>>>
>>> The /MacintoshHD/android-sdk/ directory contains these items:
>>> add-ons
>>> platform-tools
>>> platforms
>>> sources
>>> system-images
>>> temp
>>> tools
>>> tools_r24.4.1-macosx.zip
>>>
>>>
>>> Any other thoughts or advise?  Maybe I’m destined to only make iPhone
>>> apps?
>>>
>>> -Dan
>>> _______________________________________________
>>> use-livecode mailing list
>>> use-livecode at lists.runrev.com
>>> Please visit this url to subscribe, unsubscribe and manage your
>>> subscription preferences:
>>> http://lists.runrev.com/mailman/listinfo/use-livecode
>>>
>>
>>
>



More information about the Use-livecode mailing list